Why can't I install or update BandLab on my Android device?

If you're using any of the following Android devices, you may not be able to install or update the BandLab Mobile app due to certain hardware and operating system limitations:

Infinix

  • Infinix-X612 (SMART HD)
  • Infinix-X657 (SMART) Infinix Infinix-X657C (SMART 5)
  • Infinix-X657B (SMART)
  • Infinix-X680 (Infinix HOT 9 Play)
  • Infinix-X688C (HOT Play)
  • Infinix-X612B (SMART HD )
  • Infinix-X6511G (SMART 6 PLUS)
  • Infinix-X680D (Infinix SMART 4 Plus)
  • Infinix-X6516
  • Infinix-X688B
  • Infinix-X669C
  • Infinix-X6515
  • Infinix-X6517
  • Infinix-X670

TECNO

  • TECNO-KD7 (TECNO SPARK 5 Pro)
  • TECNO-KF6i (TECNO SPARK 7)
  • TECNO-KE5 (SPARK Go 2021)(SPARK 6 Go)
  • TECNO-KC8 (SPARK 4)
  • TECNO-KD6 (SPARK 5 Air)
  • TECNO-BB2 (TECNO POP 3)
  • TECNO-KG6 (TECNO SPARK 8)
  • TECNO-BC2 (TECNO POP 4)
  • TECNO-KD7h (TECNO SPARK 5)
  • TECNO-BE7 (TECNO POP 6 Go)
  • TECNO-BD2d (TECNO POP 5)
  • TECNO-BD2 (TECNO POP 5)
  • TECNO-B1g (TECNO POP 2F)
  • TECNO-PR651E (TECNO SPARK 7)
  • TECNO-KE6 (SPARK 6 Air)
  • TECNO-LC7 ( Pouvoir 4)
  • TECNO-CD6 (CAMON 15 Air)
  • TECNO-CD6j (CAMON 16 S)
  • TECNO-LC6 (Pouvoir 3 Air)
  • TECNO TECNO-BF6
  • TECNO-BF7
  • TECNO-KI7
  • TECNO-KG5k

Itel

  • Itel-A661W (A58)
  • Itel-A632WM
  • Itel-W5002 (A35)
  • Itel-L5006S (A23 Pro)
  • Itel-A631W-R2 (itel A58 Lite)
  • Itel-S661W (itel S17)
  • Itel-S663L
  • Itel-P661W (P38)
  • Itel-P662L
  • Itel-A16-Plus (itel-A16-Plus)
  • Itel-A571W (A37)
  • Itel-A512W (itel A18)
  • Itel-W6502 (S16)
  • Itel-P651W (P37)
  • Itel-A662L (itel A60)
  • Itel-A662LM
25 out of 49 found this helpful